<!DOCTYPE html><html lang="en-US"><head><meta charset="UTF-8" />
<script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.pel=(function(){var pixels=[],pxURL="/porpoiseant/army.gif";function AddAndFirePixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0);Fire();}
function AddAndFireOrigPixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0,true);Fire();}
function GetCurrentPixels(){return pixels;}
function AddPixel(adSlot,pixelData,revenue,est_revenue,bid_floor_filled,bid_floor_prev,stat_source_id,isOrig){if(!__ez.dot.isDefined(adSlot)||__ez.dot.isAnyDefined(adSlot.getSlotElementId,adSlot.ElementId)==false){return;}
var ad_position_id=parseInt(__ez.dot.getTargeting(adSlot,'ap'));var impId=__ez.dot.getSlotIID(adSlot),adUnit=__ez.dot.getAdUnit(adSlot,isOrig);var compId=parseInt(__ez.dot.getTargeting(adSlot,"compid"));var lineItemId=0;var creativeId=0;var ezimData=getEzimData(adSlot);if(typeof ezimData=='object'){if(ezimData.creative_id!==undefined){creativeId=ezimData.creative_id;}
if(ezimData.line_item_id!==undefined){lineItemId=ezimData.line_item_id;}}
if(__ez.dot.isDefined(impId,adUnit)&&__ez.dot.isValid(pixelData)){pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),revenue:revenue,est_revenue:est_revenue,ad_position:ad_position_id,ad_size:"",bid_floor_filled:bid_floor_filled,bid_floor_prev:bid_floor_prev,stat_source_id:stat_source_id,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:compId,line_item_id:lineItemId,creative_id:creativeId,data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig,});}}
function AddPixelById(impFullId,pixelData,isOrig){var vals=impFullId.split('/');if(__ez.dot.isDefined(impFullId)&&vals.length===3&&__ez.dot.isValid(pixelData)){var adUnit=vals[0],impId=vals[2];pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig});}}
function Fire(){if(typeof document.visibilityState!=='undefined'&&document.visibilityState==="prerender")return;if(__ez.dot.isDefined(pixels)&&pixels.length>0){var allPixels=[pixels.filter(function(pixel){return pixel.is_orig}),pixels.filter(function(pixel){return!pixel.is_orig})];allPixels.forEach(function(pixels){while(pixels.length>0){var isOrig=pixels[0].is_orig||false;var j=5;if(j>pixels.length){j=pixels.length;}
var pushPixels=pixels.splice(0,j);var pixelURL=__ez.dot.getURL(pxURL)+"?orig="+(isOrig===true?1:0)+"&sts="+btoa(JSON.stringify(pushPixels));if(typeof window.isAmp!=='undefined'&&isAmp&&typeof window._ezaq!=='undefined'&&_ezaq.hasOwnProperty("domain_id")){pixelURL+="&visit_uuid="+_ezaq['visit_uuid'];}
__ez.dot.Fire(pixelURL);}})}
pixels=[];}
function getEzimData(adSlot){if(typeof _ezim_d=="undefined"){return false}
var adUnitName=__ez.dot.getAdUnitPath(adSlot).split('/').pop();if(typeof _ezim_d==='object'&&_ezim_d.hasOwnProperty(adUnitName)){return _ezim_d[adUnitName];}
for(var ezimKey in _ezim_d){if(ezimKey.split('/').pop()===adUnitName){return _ezim_d[ezimKey];}}
return false;}
return{Add:AddPixel,AddAndFire:AddAndFirePixel,AddAndFireOrig:AddAndFireOrigPixel,AddById:AddPixelById,Fire:Fire,GetPixels:GetCurrentPixels,};})();__ez.queue.addFile('/detroitchicago/raleigh.js', '/detroitchicago/raleigh.js?gcb=194-0&cb=5', false, [], true, false, true, false);__ez.queue.addFile('/detroitchicago/tampa.js', '/detroitchicago/tampa.js?gcb=194-0&cb=3', false, [], true, false, true, false);</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">__ez.queue.addFile('/detroitchicago/tulsa.js', '/detroitchicago/tulsa.js?gcb=194-0&cb=5', false, [], true, false, true, false);</script><meta name="viewport" content="width=device-width, initial-scale=1" /><link rel="profile" href="https://gmpg.org/xfn/11" /><meta name="robots" content="index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1" /><link media="all" href="https://linuxsmartphones.com/wp-content/cache/autoptimize/css/autoptimize_897a010db4cdfc0c6eecdf7e37912073.css" rel="stylesheet" /><link media="print" href="https://linuxsmartphones.com/wp-content/cache/autoptimize/css/autoptimize_77bb8ce76faabf20346e3250e3d87967.css" rel="stylesheet" /><title>Virtual mouse app for Linux phones makes desktop apps easier to use - Linux Smartphones</title><meta name="description" content="Virtual mouse app for Linux phones makes desktop apps easier to use" /><link rel="canonical" href="https://linuxsmartphones.com/virtual-mouse-app-for-linux-phones-makes-desktop-apps-easier-to-use/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Virtual mouse app for Linux phones makes desktop apps easier to use - Linux Smartphones" /><meta property="og:description" content="Virtual mouse app for Linux phones makes desktop apps easier to use" /><meta property="og:url" content="https://linuxsmartphones.com/virtual-mouse-app-for-linux-phones-makes-desktop-apps-easier-to-use/" /><meta property="og:site_name" content="Linux Smartphones" /><meta property="article:publisher" content="https://www.facebook.com/LinuxSmartphones/" /><meta property="article:published_time" content="2021-04-30T14:48:12+00:00" /><meta property="og:image" content="https://linuxsmartphones.com/wp-content/uploads/2021/04/touchpademulator.jpg" /><meta property="og:image:width" content="1200" /><meta property="og:image:height" content="673" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:creator" content="@linuxsmartphone" /><meta name="twitter:site" content="@linuxsmartphone" /><meta name="twitter:label1" content="Written by" /><meta name="twitter:data1" content="Brad Linder" /><meta name="twitter:label2" content="Est. reading time" /><meta name="twitter:data2" content="2 minutes" /> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://linuxsmartphones.com/#organization","name":"Linux Smartphones","url":"https://linuxsmartphones.com/","sameAs":["https://www.facebook.com/LinuxSmartphones/","https://www.youtube.com/liliputing","https://twitter.com/linuxsmartphone"],"logo":{"@type":"ImageObject","@id":"https://linuxsmartphones.com/#logo","inLanguage":"en-US","url":"https://linuxsmartphones.com/wp-content/uploads/2020/09/LS-Logo.png","contentUrl":"https://linuxsmartphones.com/wp-content/uploads/2020/09/LS-Logo.png","width":800,"height":800,"caption":"Linux Smartphones"},"image":{"@id":"https://linuxsmartphones.com/#logo"}},{"@type":"WebSite","@id":"https://linuxsmartphones.com/#website","url":"https://linuxsmartphones.com/","name":"Linux Smartphones","description":"","publisher":{"@id":"https://linuxsmartphones.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://linuxsmartphones.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://linuxsmartphones.com/virtual-mouse-app-for-linux-phones-makes-desktop-apps-easier-to-use/#primaryimage","inLanguage":"en-US","url":"https://linuxsmartphones.com/wp-content/uploads/2021/04/touchpademulator.jpg","contentUrl":"https://linuxsmartphones.com/wp-content/uploads/2021/04/touchpademulator.jpg","width":1200,"height":673},{"@type":"WebPage","@id":"https://linuxsmartphones.com/virtual-mouse-app-for-linux-phones-makes-desktop-apps-easier-to-use/#webpage","url":"https://linuxsmartphones.com/virtual-mouse-app-for-linux-phones-makes-desktop-apps-easier-to-use/","name":"Virtual mouse app for Linux phones makes desktop apps easier to use - Linux Smartphones","isPartOf":{"@id":"https://linuxsmartphones.com/#website"},"primaryImageOfPage":{"@id":"https://linuxsmartphones.com/virtual-mouse-app-for-linux-phones-makes-desktop-apps-easier-to-use/#primaryimage"},"datePublished":"2021-04-30T14:48:12+00:00","dateModified":"2021-04-30T14:48:12+00:00","description":"Virtual mouse app for Linux phones makes desktop apps easier to use","breadcrumb":{"@id":"https://linuxsmartphones.com/virtual-mouse-app-for-linux-phones-makes-desktop-apps-easier-to-use/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://linuxsmartphones.com/virtual-mouse-app-for-linux-phones-makes-desktop-apps-easier-to-use/"]}]},{"@type":"BreadcrumbList","@id":"https://linuxsmartphones.com/virtual-mouse-app-for-linux-phones-makes-desktop-apps-easier-to-use/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://linuxsmartphones.com/","url":"https://linuxsmartphones.com/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@id":"https://linuxsmartphones.com/virtual-mouse-app-for-linux-phones-makes-desktop-apps-easier-to-use/#webpage"}}]},{"@type":"Article","@id":"https://linuxsmartphones.com/virtual-mouse-app-for-linux-phones-makes-desktop-apps-easier-to-use/#article","isPartOf":{"@id":"https://linuxsmartphones.com/virtual-mouse-app-for-linux-phones-makes-desktop-apps-easier-to-use/#webpage"},"author":{"@id":"https://linuxsmartphones.com/#/schema/person/c8c1cf703925f5a8f3665a6140bab69c"},"headline":"Virtual mouse app for Linux phones makes desktop apps easier to use","datePublished":"2021-04-30T14:48:12+00:00","dateModified":"2021-04-30T14:48:12+00:00","mainEntityOfPage":{"@id":"https://linuxsmartphones.com/virtual-mouse-app-for-linux-phones-makes-desktop-apps-easier-to-use/#webpage"},"commentCount":0,"publisher":{"@id":"https://linuxsmartphones.com/#organization"},"image":{"@id":"https://linuxsmartphones.com/virtual-mouse-app-for-linux-phones-makes-desktop-apps-easier-to-use/#primaryimage"},"keywords":["apps","calcprogrammer1","input","mouse emulator","pinephone","touchpademulator","virtual mouse"],"articleSection":["News"],"inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://linuxsmartphones.com/virtual-mouse-app-for-linux-phones-makes-desktop-apps-easier-to-use/#respond"]}]},{"@type":"Person","@id":"https://linuxsmartphones.com/#/schema/person/c8c1cf703925f5a8f3665a6140bab69c","name":"Brad Linder","image":{"@type":"ImageObject","@id":"https://linuxsmartphones.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/558f8da606ef78c7c9214fb9cc2bb0a1?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/558f8da606ef78c7c9214fb9cc2bb0a1?s=96&d=mm&r=g","caption":"Brad Linder"},"sameAs":["http://linuxsmartphones.com"]}]}</script> <link rel="dns-prefetch" href="//secure.gravatar.com" /><link rel="dns-prefetch" href="//fonts.googleapis.com" /><link rel="dns-prefetch" href="//s.w.org" /><link rel="dns-prefetch" href="//v0.wordpress.com" /><link rel="dns-prefetch" href="//s.pubmine.com" /><link rel="dns-prefetch" href="//x.bidswitch.net" /><link rel="dns-prefetch" href="//static.criteo.net" /><link rel="dns-prefetch" href="//ib.adnxs.com" /><link rel="dns-prefetch" href="//aax.amazon-adsystem.com" /><link rel="dns-prefetch" href="//bidder.criteo.com" /><link rel="dns-prefetch" href="//cas.criteo.com" /><link rel="dns-prefetch" href="//gum.criteo.com" /><link rel="dns-prefetch" href="//ads.pubmatic.com" /><link rel="dns-prefetch" href="//gads.pubmatic.com" /><link rel="dns-prefetch" href="//tpc.googlesyndication.com" /><link rel="dns-prefetch" href="//ad.doubleclick.net" /><link rel="dns-prefetch" href="//googleads.g.doubleclick.net" /><link rel="dns-prefetch" href="//www.googletagservices.com" /><link rel="dns-prefetch" href="//cdn.switchadhub.com" /><link rel="dns-prefetch" href="//delivery.g.switchadhub.com" /><link rel="dns-prefetch" href="//delivery.swid.switchadhub.com" /><link rel="alternate" type="application/rss+xml" title="Linux Smartphones » Feed" href="https://linuxsmartphones.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Linux Smartphones » Comments Feed" href="https://linuxsmartphones.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Linux Smartphones » Virtual mouse app for Linux phones makes desktop apps easier to use Comments Feed" href="https://linuxsmartphones.com/virtual-mouse-app-for-linux-phones-makes-desktop-apps-easier-to-use/feed/" /> <script type="text/javascript">window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/linuxsmartphones.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.7.1"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);</script> <link crossorigin="anonymous" rel="stylesheet" id="newspack-katharine-fonts-css" href="https://fonts.googleapis.com/css?family=Barlow%3A400%2C400i%2C700%2C700i&amp;subset=latin%2Clatin-ext&amp;display=swap" type="text/css" media="all" /> <script type="text/javascript" src="https://linuxsmartphones.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1" id="jquery-core-js"></script> <link rel="https://api.w.org/" href="https://linuxsmartphones.com/wp-json/" /><link rel="alternate" type="application/json" href="https://linuxsmartphones.com/wp-json/wp/v2/posts/800" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://linuxsmartphones.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://linuxsmartphones.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.7.1" /><link rel="shortlink" href="https://linuxsmartphones.com/?p=800" /><link rel="alternate" type="application/json+oembed" href="https://linuxsmartphones.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Flinuxsmartphones.com%2Fvirtual-mouse-app-for-linux-phones-makes-desktop-apps-easier-to-use%2F" /><link rel="alternate" type="text/xml+oembed" href="https://linuxsmartphones.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Flinuxsmartphones.com%2Fvirtual-mouse-app-for-linux-phones-makes-desktop-apps-easier-to-use%2F&amp;format=xml" /> <script>document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);</script> <link rel="amphtml" href="https://linuxsmartphones.com/virtual-mouse-app-for-linux-phones-makes-desktop-apps-easier-to-use/?amp" /> <script data-cfasync="&#34;false&#34;" type="text/javascript">var __ATA_PP = { pt: 1, ht: 2, tn: 'newspack-katharine', amp: false, siteid: 182311836, consent: 0 };
			var __ATA = __ATA || {};
			__ATA.cmd = __ATA.cmd || [];
			__ATA.criteo = __ATA.criteo || {};
			__ATA.criteo.cmd = __ATA.criteo.cmd || [];</script> <script data-cfasync="&#34;false&#34;" type="text/javascript">(function(){var g=Date.now||function(){return+new Date};function h(a,b){a:{for(var c=a.length,d="string"==typeof a?a.split(""):a,e=0;e<c;e++)if(e in d&&b.call(void 0,d[e],e,a)){b=e;break a}b=-1}return 0>b?null:"string"==typeof a?a.charAt(b):a[b]};function k(a,b,c){c=null!=c?"="+encodeURIComponent(String(c)):"";if(b+=c){c=a.indexOf("#");0>c&&(c=a.length);var d=a.indexOf("?");if(0>d||d>c){d=c;var e=""}else e=a.substring(d+1,c);a=[a.substr(0,d),e,a.substr(c)];c=a[1];a[1]=b?c?c+"&"+b:b:c;a=a[0]+(a[1]?"?"+a[1]:"")+a[2]}return a};var l=0;function m(a,b){var c=document.createElement("script");c.src=a;c.onload=function(){b&&b(void 0)};c.onerror=function(){b&&b("error")};a=document.getElementsByTagName("head");var d;a&&0!==a.length?d=a[0]:d=document.documentElement;d.appendChild(c)}function n(a){var b=void 0===b?document.cookie:b;return(b=h(b.split("; "),function(c){return-1!=c.indexOf(a+"=")}))?b.split("=")[1]:""}function p(a){return"string"==typeof a&&0<a.length}
		function r(a,b,c){b=void 0===b?"":b;c=void 0===c?".":c;var d=[];Object.keys(a).forEach(function(e){var f=a[e],q=typeof f;"object"==q&&null!=f||"function"==q?d.push(r(f,b+e+c)):null!==f&&void 0!==f&&(e=encodeURIComponent(b+e),d.push(e+"="+encodeURIComponent(f)))});return d.filter(p).join("&")}function t(a,b){a||((window.__ATA||{}).config=b.c,m(b.url))}var u=Math.floor(1E13*Math.random()),v=window.__ATA||{};window.__ATA=v;window.__ATA.cmd=v.cmd||[];v.rid=u;v.createdAt=g();var w=window.__ATA||{},x="s.pubmine.com";
		w&&w.serverDomain&&(x=w.serverDomain);var y="//"+x+"/conf",z=window.top===window,A=window.__ATA_PP&&window.__ATA_PP.gdpr_applies,B="boolean"===typeof A?Number(A):null,C=window.__ATA_PP||null,D=z?document.referrer?document.referrer:null:null,E=z?window.location.href:document.referrer?document.referrer:null,F,G=n("__ATA_tuuid");F=G?G:null;var H=window.innerWidth+"x"+window.innerHeight,I=n("usprivacy"),J=r({gdpr:B,pp:C,rid:u,src:D,ref:E,tuuid:F,vp:H,us_privacy:I?I:null},"",".");
		(function(a){var b=void 0===b?"cb":b;l++;var c="callback__"+g().toString(36)+"_"+l.toString(36);a=k(a,b,c);window[c]=function(d){t(void 0,d)};m(a,function(d){d&&t(d)})})(y+"?"+J);}).call(this);</script> <link rel="icon" href="https://linuxsmartphones.com/wp-content/uploads/2020/09/cropped-LS-Logo-32x32.png" sizes="32x32" /><link rel="icon" href="https://linuxsmartphones.com/wp-content/uploads/2020/09/cropped-LS-Logo-192x192.png" sizes="192x192" /><link rel="apple-touch-icon" href="https://linuxsmartphones.com/wp-content/uploads/2020/09/cropped-LS-Logo-180x180.png" /><meta name="msapplication-TileImage" content="https://linuxsmartphones.com/wp-content/uploads/2020/09/cropped-LS-Logo-270x270.png" /> <script async="" src="https://www.googletagmanager.com/gtag/js?id=UA-177064617-1"></script> <script>window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-177064617-1');</script> <script data-ad-client="ca-pub-2998039209070153" async="" src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script>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</script> <script type="text/javascript">var ezouid = "1";</script><base href="https://linuxsmartphones.com/virtual-mouse-app-for-linux-phones-makes-desktop-apps-easier-to-use/"><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script>
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 243656;
var ezdomain = 'linuxsmartphones.com';
var ezoicSearchable = 1;
</script>


<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"ad_load_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":243656,"engaged_time_visit":0,"ezcache_level":0,"ezcache_skip_code":0,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"85824768-82d1-4fec-51f3-7e3939a67832","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_size_orig":116940,"response_time_orig":456,"serverid":"18.185.39.6:16591","state":"VA","t_epoch":1619799793,"template_id":126,"time_on_site_visit":0,"url":"https://linuxsmartphones.com/virtual-mouse-app-for-linux-phones-makes-desktop-apps-easier-to-use/","user_id":0,"word_count":810,"worst_bad_word_level":0};var _ezExtraQueries = "&ez_orig=1";</script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl(pvID, rv) {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_243656=" + new Date().getTime() + "|" + pvID + "|" + rv + "; " + expires, 3);
}
function attach_ezolpl(pvID, rv) {
    if (document.readyState === "complete") {
        create_ezolpl(pvID, rv);
    }
    if(window.attachEvent) {
        window.attachEvent("onload", create_ezolpl, pvID, rv);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl(pvID, rv);
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl.bind(null, pvID, rv);
        }
    }
}

__ez.queue.addFunc("attach_ezolpl", "attach_ezolpl", ["85824768-82d1-4fec-51f3-7e3939a67832", "false"], false, ['/detroitchicago/boise.js'], true, false, false, false);
</script></head><body class="post-template-default single single-post postid-800 single-format-standard wp-custom-logo wp-embed-responsive singular hide-site-tagline h-nsub h-sb h-ll h-sh has-sidebar cat-news single-featured-image-default categories-hidden"><aside id="mobile-sidebar-fallback" class="mobile-sidebar"> <button class="mobile-menu-toggle"> <svg class="svg-icon" width="20" height="20" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24"><path d="M19 6.41L17.59 5 12 10.59 6.41 5 5 6.41 10.59 12 5 17.59 6.41 19 12 13.41 17.59 19 19 17.59 13.41 12z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg> Close </button><form role="search" method="get" class="search-form" action="https://linuxsmartphones.com/"> <label for="search-form-1"> <span class="screen-reader-text">Search for:</span> </label> <input type="search" id="search-form-1" class="search-field" placeholder="Search …" value="" name="s" /> <button type="submit" class="search-submit"> <svg class="svg-icon" width="28" height="28" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24"><path d="M15.5 14h-.79l-.28-.27C15.41 12.59 16 11.11 16 9.5 16 5.91 13.09 3 9.5 3S3 5.91 3 9.5 5.91 16 9.5 16c1.61 0 3.09-.59 4.23-1.57l.27.28v.79l5 4.99L20.49 19l-4.99-5zm-6 0C7.01 14 5 11.99 5 9.5S7.01 5 9.5 5 14 7.01 14 9.5 11.99 14 9.5 14z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg> <span class="screen-reader-text"> Search </span> </button></form><nav class="main-navigation nav1 dd-menu" aria-label="Top Menu" toolbar-target="site-navigation" toolbar="(min-width: 767px)"><ul id="menu-nav" class="main-menu"><li id="menu-item-51" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-51"><a href="https://linuxsmartphones.com/category/news/">News</a></li><li id="menu-item-95" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-95"><a target="_blank" rel="nofollow" href="https://liliputing.com/">Liliputing</a></li><li id="menu-item-675" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-675"><a href="https://linuxsmartphones.com/mobile-linux-distributions/">Mobile Linux distros</a></li><li id="menu-item-115" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-115"><a href="https://linuxsmartphones.com/phones/" aria-haspopup="true" aria-expanded="false">Phone Specs</a><button class="submenu-expand" tabindex="-1" role="presentation"><svg class="svg-icon" width="24" height="24" aria-hidden="true" role="img" focusable="false" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24"><path d="M7.41 8.59L12 13.17l4.59-4.58L18 10l-6 6-6-6 1.41-1.41z"></path><path fill="none" d="M0 0h24v24H0V0z"></path></svg></button><ul class="sub-menu"><li id="menu-item-219" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-219"><a href="https://linuxsmartphones.com/phones/">Compare Linux phone specs</a></li><li id="menu-item-116" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-116"><a href="https://linuxsmartphones.com/phones/pinephone-specs/">PinePhone Specs</a></li><li id="menu-item-117" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-117"><a href="https://linuxsmartphones.com/phones/purism-librem-5-specs/">Purism Librem 5 specs</a></li><li id="menu-item-215" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-215"><a href="https://linuxsmartphones.com/phones/volla-phone-specs/">Volla Phone specs</a></li><li id="menu-item-319" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-319"><a href="https://linuxsmartphones.com/phones/fxtec-pro1-x-specs/">F(x)tec Pro1-X specs</a></li><li id="menu-item-330" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-330"><a href="https://linuxsmartphones.com/phones/cosmo-communicator-specs/">Cosmo Communicator Specs</a></li></ul></li><li id="menu-item-676" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-676"><a aria-haspopup="true" aria-expanded="false">About</a><button class="submenu-expand" tabindex="-1" role="presentation"><svg class="svg-icon" width="24" height="24" aria-hidden="true" role="img" focusable="false" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24"><path d="M7.41 8.59L12 13.17l4.59-4.58L18 10l-6 6-6-6 1.41-1.41z"></path><path fill="none" d="M0 0h24v24H0V0z"></path></svg></button><ul class="sub-menu"><li id="menu-item-41" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-41"><a href="https://linuxsmartphones.com/about-linux-smartphones/">About LinuxSmartphones.com</a></li><li id="menu-item-45" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-45"><a href="https://linuxsmartphones.com/contact-us/">Contact Us</a></li></ul></li></ul></nav></aside><aside id="desktop-sidebar-fallback" class="desktop-sidebar dir-left"> <button class="desktop-menu-toggle"> <svg class="svg-icon" width="20" height="20" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24"><path d="M19 6.41L17.59 5 12 10.59 6.41 5 5 6.41 10.59 12 5 17.59 6.41 19 12 13.41 17.59 19 19 17.59 13.41 12z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg> Close </button></aside><div id="page" class="site"> <a class="skip-link screen-reader-text" href="#content">Skip to content</a><header id="masthead" class="site-header hide-header-search" [class]="searchVisible ? &#39;show-header-search site-header &#39; : &#39;hide-header-search site-header&#39;"><div class="middle-header-contain"><div class="wrapper"><div class="site-branding"> <a href="https://linuxsmartphones.com/" class="custom-logo-link" rel="home"><img width="800" height="800" src="https://linuxsmartphones.com/wp-content/uploads/2020/09/LS-Logo_s.png" class="custom-logo jetpack-lazy-image" alt="Linux Smartphones" data-attachment-id="167" data-permalink="https://linuxsmartphones.com/ls-logo_s/" data-orig-file="https://linuxsmartphones.com/wp-content/uploads/2020/09/LS-Logo_s.png" data-orig-size="800,800" data-comments-opened="1" data-image-meta="{&#34;aperture&#34;:&#34;0&#34;,&#34;credit&#34;:&#34;&#34;,&#34;camera&#34;:&#34;&#34;,&#34;caption&#34;:&#34;&#34;,&#34;created_timestamp&#34;:&#34;0&#34;,&#34;copyright&#34;:&#34;&#34;,&#34;focal_length&#34;:&#34;0&#34;,&#34;iso&#34;:&#34;0&#34;,&#34;shutter_speed&#34;:&#34;0&#34;,&#34;title&#34;:&#34;&#34;,&#34;orientation&#34;:&#34;0&#34;}" data-image-title="LS Logo_s" data-image-description="" data-medium-file="https://linuxsmartphones.com/wp-content/uploads/2020/09/LS-Logo_s-400x400.png" data-large-file="https://linuxsmartphones.com/wp-content/uploads/2020/09/LS-Logo_s-500x500.png" data-lazy-srcset="https://linuxsmartphones.com/wp-content/uploads/2020/09/LS-Logo_s.png 800w, https://linuxsmartphones.com/wp-content/uploads/2020/09/LS-Logo_s-400x400.png 400w, https://linuxsmartphones.com/wp-content/uploads/2020/09/LS-Logo_s-500x500.png 500w, https://linuxsmartphones.com/wp-content/uploads/2020/09/LS-Logo_s-150x150.png 150w, https://linuxsmartphones.com/wp-content/uploads/2020/09/LS-Logo_s-768x768.png 768w" data-lazy-sizes="(max-width: 800px) 100vw, 800px" data-lazy-src="https://linuxsmartphones.com/wp-content/uploads/2020/09/LS-Logo_s.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a><div class="site-identity"><p class="site-title"><a href="https://linuxsmartphones.com/" rel="home">Linux Smartphones</a></p></div></div><div class="nav-wrapper desktop-only"><div id="site-navigation"><nav class="main-navigation nav1 dd-menu" aria-label="Top Menu" toolbar-target="site-navigation" toolbar="(min-width: 767px)"><ul id="menu-nav-1" class="main-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-51"><a href="https://linuxsmartphones.com/category/news/">News</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-95"><a target="_blank" rel="nofollow" href="https://liliputing.com/">Liliputing</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-675"><a href="https://linuxsmartphones.com/mobile-linux-distributions/">Mobile Linux distros</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-115"><a href="https://linuxsmartphones.com/phones/" aria-haspopup="true" aria-expanded="false">Phone Specs</a><button class="submenu-expand" tabindex="-1" role="presentation"><svg class="svg-icon" width="24" height="24" aria-hidden="true" role="img" focusable="false" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24"><path d="M7.41 8.59L12 13.17l4.59-4.58L18 10l-6 6-6-6 1.41-1.41z"></path><path fill="none" d="M0 0h24v24H0V0z"></path></svg></button><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-219"><a href="https://linuxsmartphones.com/phones/">Compare Linux phone specs</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-116"><a href="https://linuxsmartphones.com/phones/pinephone-specs/">PinePhone Specs</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-117"><a href="https://linuxsmartphones.com/phones/purism-librem-5-specs/">Purism Librem 5 specs</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-215"><a href="https://linuxsmartphones.com/phones/volla-phone-specs/">Volla Phone specs</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-319"><a href="https://linuxsmartphones.com/phones/fxtec-pro1-x-specs/">F(x)tec Pro1-X specs</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-330"><a href="https://linuxsmartphones.com/phones/cosmo-communicator-specs/">Cosmo Communicator Specs</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-676"><a aria-haspopup="true" aria-expanded="false">About</a><button class="submenu-expand" tabindex="-1" role="presentation"><svg class="svg-icon" width="24" height="24" aria-hidden="true" role="img" focusable="false" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24"><path d="M7.41 8.59L12 13.17l4.59-4.58L18 10l-6 6-6-6 1.41-1.41z"></path><path fill="none" d="M0 0h24v24H0V0z"></path></svg></button><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-post menu-item-41"><a href="https://linuxsmartphones.com/about-linux-smartphones/">About LinuxSmartphones.com</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-45"><a href="https://linuxsmartphones.com/contact-us/">Contact Us</a></li></ul></li></ul></nav></div></div><div class="nav-wrapper desktop-only"><div id="tertiary-nav-contain"></div><div class="header-search-contain"> <button id="search-toggle" on="tap:AMP.setState( { searchVisible: !searchVisible } ), search-form-2.focus" aria-controls="search-menu" [aria-expanded]="searchVisible ? &#39;true&#39; : &#39;false&#39;" aria-expanded="false"> <span class="screen-reader-text" [text]="searchVisible ? &#39;Close Search&#39; : &#39;Open Search&#39;"> Open Search </span> <span class="search-icon"><svg class="svg-icon" width="28" height="28" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24"><path d="M15.5 14h-.79l-.28-.27C15.41 12.59 16 11.11 16 9.5 16 5.91 13.09 3 9.5 3S3 5.91 3 9.5 5.91 16 9.5 16c1.61 0 3.09-.59 4.23-1.57l.27.28v.79l5 4.99L20.49 19l-4.99-5zm-6 0C7.01 14 5 11.99 5 9.5S7.01 5 9.5 5 14 7.01 14 9.5 11.99 14 9.5 14z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg></span> <span class="close-icon"><svg class="svg-icon" width="28" height="28" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24"><path d="M19 6.41L17.59 5 12 10.59 6.41 5 5 6.41 10.59 12 5 17.59 6.41 19 12 13.41 17.59 19 19 17.59 13.41 12z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg></span> </button><div id="header-search" [aria-expanded]="searchVisible ? &#39;true&#39; : &#39;false&#39;" aria-expanded="false"><form role="search" method="get" class="search-form" action="https://linuxsmartphones.com/"> <label for="search-form-2"> <span class="screen-reader-text">Search for:</span> </label> <input type="search" id="search-form-2" class="search-field" placeholder="Search …" value="" name="s" /> <button type="submit" class="search-submit"> <svg class="svg-icon" width="28" height="28" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24"><path d="M15.5 14h-.79l-.28-.27C15.41 12.59 16 11.11 16 9.5 16 5.91 13.09 3 9.5 3S3 5.91 3 9.5 5.91 16 9.5 16c1.61 0 3.09-.59 4.23-1.57l.27.28v.79l5 4.99L20.49 19l-4.99-5zm-6 0C7.01 14 5 11.99 5 9.5S7.01 5 9.5 5 14 7.01 14 9.5 11.99 14 9.5 14z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg> <span class="screen-reader-text"> Search </span> </button></form></div></div></div> <button class="mobile-menu-toggle" on="tap:mobile-sidebar.toggle"> <svg class="svg-icon" width="20" height="20" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24"><path d="M0 0h24v24H0z" fill="none"></path><path d="M3 18h18v-2H3v2zm0-5h18v-2H3v2zm0-7v2h18V6H3z"></path></svg> <span>Menu</span> </button></div></div></header><div id="content" class="site-content"><section id="primary" class="content-area category-news tag-apps tag-calcprogrammer1 tag-input tag-mouse-emulator tag-pinephone tag-touchpademulator tag-virtual-mouse"><main id="main" class="site-main"><div class="code-block code-block-2" style="margin: 8px auto; text-align: center; display: block; clear: both;"></div><header class="entry-header"> <span class="cat-links"><span class="screen-reader-text">Posted in</span><a href="https://linuxsmartphones.com/category/news/" rel="category tag">News</a></span><h1 class="entry-title "> Virtual mouse app for Linux phones makes desktop apps easier to use</h1><div class="entry-subhead"><div class="entry-meta"> <span class="author-avatar"><img alt="" src="https://secure.gravatar.com/avatar/558f8da606ef78c7c9214fb9cc2bb0a1?s=96&amp;d=mm&amp;r=g" class="avatar avatar-96 photo jetpack-lazy-image" height="96" width="96" loading="lazy" data-lazy-srcset="https://secure.gravatar.com/avatar/558f8da606ef78c7c9214fb9cc2bb0a1?s=192&amp;d=mm&amp;r=g 2x" data-lazy-src="https://secure.gravatar.com/avatar/558f8da606ef78c7c9214fb9cc2bb0a1?s=96&amp;is-pending-load=1#038;d=mm&amp;r=g" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /><noscript><img alt='' src='https://secure.gravatar.com/avatar/558f8da606ef78c7c9214fb9cc2bb0a1?s=96&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/558f8da606ef78c7c9214fb9cc2bb0a1?s=192&#038;d=mm&#038;r=g 2x' class='avatar avatar-96 photo' height='96' width='96' loading='lazy'/></noscript></span><span class="byline"><span>by</span> <span class="author vcard"><a class="url fn n" href="https://linuxsmartphones.com/author/bradlinder/">Brad Linder</a></span></span><span class="posted-on"><time class="entry-date published updated" datetime="2021-04-30T10:48:12-04:00">April 30, 2021</time></span></div><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-800" class="share-twitter sd-button share-icon" href="https://linuxsmartphones.com/virtual-mouse-app-for-linux-phones-makes-desktop-apps-easier-to-use/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-800" class="share-facebook sd-button share-icon" href="https://linuxsmartphones.com/virtual-mouse-app-for-linux-phones-makes-desktop-apps-easier-to-use/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon" href="https://linuxsmartphones.com/virtual-mouse-app-for-linux-phones-makes-desktop-apps-easier-to-use/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-pinterest"><a rel="nofollow noopener noreferrer" data-shared="sharing-pinterest-800" class="share-pinterest sd-button share-icon" href="https://linuxsmartphones.com/virtual-mouse-app-for-linux-phones-makes-desktop-apps-easier-to-use/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span>Pinterest</span></a></li><li class="share-pocket"><a rel="nofollow noopener noreferrer" data-shared="" class="share-pocket sd-button share-icon" href="https://linuxsmartphones.com/virtual-mouse-app-for-linux-phones-makes-desktop-apps-easier-to-use/?share=pocket" target="_blank" title="Click to share on Pocket"><span>Pocket</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-800" class="share-linkedin sd-button share-icon" href="https://linuxsmartphones.com/virtual-mouse-app-for-linux-phones-makes-desktop-apps-easier-to-use/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span>LinkedIn</span></a></li><li class="share-end"></li></ul></div></div></div></div></header><div class="main-content"><article id="post-800" class="post-800 post type-post status-publish format-standard has-post-thumbnail hentry category-news tag-apps tag-calcprogrammer1 tag-input tag-mouse-emulator tag-pinephone tag-touchpademulator tag-virtual-mouse entry"><div class="entry-content"><p>Linux phones are basically just small, low-power Linux computers with touchscreens, and modems. While most mobile Linux distributions designed for phones feature touch-friendly user interfaces and apps, you can also run desktop applications on a Linux phone.</p><p>But you may have trouble actually <em>using</em> software that obviously weren’t designed for small screens, because it can be hard to navigate applications designed for keyboard and mouse input when you’re using a fingertip.</p><p>So developer CalcProgrammer1 was looking for a way to use the touchscreen on a Linux phone to emulate a mouse or touchpad. And when he didn’t find one, he decided to build one. It’s called <strong>TouchPadEmulator</strong> and there’s a proof-of-concept version <a href="https://gitlab.com/CalcProgrammer1/TouchpadEmulator">available at GitLab</a>.</p><p><img data-attachment-id="801" data-permalink="https://linuxsmartphones.com/virtual-mouse-app-for-linux-phones-makes-desktop-apps-easier-to-use/touchpademulator/" data-orig-file="https://linuxsmartphones.com/wp-content/uploads/2021/04/touchpademulator.jpg" data-orig-size="1200,673" data-comments-opened="1" data-image-meta="{&#34;aperture&#34;:&#34;0&#34;,&#34;credit&#34;:&#34;&#34;,&#34;camera&#34;:&#34;&#34;,&#34;caption&#34;:&#34;&#34;,&#34;created_timestamp&#34;:&#34;0&#34;,&#34;copyright&#34;:&#34;&#34;,&#34;focal_length&#34;:&#34;0&#34;,&#34;iso&#34;:&#34;0&#34;,&#34;shutter_speed&#34;:&#34;0&#34;,&#34;title&#34;:&#34;&#34;,&#34;orientation&#34;:&#34;0&#34;}" data-image-title="touchpademulator" data-image-description="" data-medium-file="https://linuxsmartphones.com/wp-content/uploads/2021/04/touchpademulator-400x224.jpg" data-large-file="https://linuxsmartphones.com/wp-content/uploads/2021/04/touchpademulator-780x437.jpg" loading="lazy" class="aligncenter size-large wp-image-801 jetpack-lazy-image" src="https://linuxsmartphones.com/wp-content/uploads/2021/04/touchpademulator-780x437.jpg" alt="" width="780" height="437" data-lazy-srcset="https://linuxsmartphones.com/wp-content/uploads/2021/04/touchpademulator-780x437.jpg 780w, https://linuxsmartphones.com/wp-content/uploads/2021/04/touchpademulator-400x224.jpg 400w, https://linuxsmartphones.com/wp-content/uploads/2021/04/touchpademulator-768x431.jpg 768w, https://linuxsmartphones.com/wp-content/uploads/2021/04/touchpademulator.jpg 1200w" data-lazy-sizes="(max-width: 780px) 100vw, 780px" data-lazy-src="https://linuxsmartphones.com/wp-content/uploads/2021/04/touchpademulator-780x437.jpg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /><noscript><img data-attachment-id="801" data-permalink="https://linuxsmartphones.com/virtual-mouse-app-for-linux-phones-makes-desktop-apps-easier-to-use/touchpademulator/" data-orig-file="https://linuxsmartphones.com/wp-content/uploads/2021/04/touchpademulator.jpg" data-orig-size="1200,673" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="touchpademulator" data-image-description="" data-medium-file="https://linuxsmartphones.com/wp-content/uploads/2021/04/touchpademulator-400x224.jpg" data-large-file="https://linuxsmartphones.com/wp-content/uploads/2021/04/touchpademulator-780x437.jpg" loading="lazy" class="aligncenter size-large wp-image-801" src="https://linuxsmartphones.com/wp-content/uploads/2021/04/touchpademulator-780x437.jpg" alt="" width="780" height="437" srcset="https://linuxsmartphones.com/wp-content/uploads/2021/04/touchpademulator-780x437.jpg 780w, https://linuxsmartphones.com/wp-content/uploads/2021/04/touchpademulator-400x224.jpg 400w, https://linuxsmartphones.com/wp-content/uploads/2021/04/touchpademulator-768x431.jpg 768w, https://linuxsmartphones.com/wp-content/uploads/2021/04/touchpademulator.jpg 1200w" sizes="(max-width: 780px) 100vw, 780px" /></noscript></p><div class="code-block code-block-3" style="margin: 8px auto; text-align: center; display: block; clear: both;"><div id="ezoic-pub-ad-placeholder-102"> <script async="" src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-2998039209070153" data-ad-slot="5023358323" data-ad-format="auto" data-full-width-responsive="true"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> </div></div><p></p><p>Here’s how TouchpadEmulator works:</p><ul><li>Hit the <strong>volume up key</strong> to <strong>trigger mouse mode</strong>.</li><li>Now you can <strong>move a cursor</strong> on the screen by <strong>dragging your finger across the display</strong>. This will help you hit tiny icons, menus, or other targets. It also makes it possible to interact with drop-down menus and/or items that respond to a hovering cursor that would otherwise be tough to use on a touch-only device.</li><li>You can <strong>tap the screen</strong> to <strong>emulate a click actions</strong>, use a <strong>2-finger tap to right-click</strong>, <strong>swipe with 2 fingers to scroll</strong>, or <strong>tap-and-hold to drag</strong> windows or other items.</li><li><strong>Switch back to touchscreen mode</strong> by <strong>pressing the volume down key</strong> when you want to use the on-screen keyboard or other touch-based navigation.</li><li><strong>Close TouchpadEmulator</strong> by <strong>pressing either volume key for 2-3 seconds</strong>.</li></ul><p>While automatic screen rotation is not yet supported, the developer notes that if you rotate the screen to portrait mode you can also press the volume-up key again to change orientation. And you can keep pressing it to cycle through different screen orientations until you’re back to the start.</p><div class="jetpack-video-wrapper"><span class="embed-youtube" style="text-align:center; display: block;"><iframe class="youtube-player" width="780" height="439" src="https://www.youtube.com/embed/C4-4rrPS0a0?version=3&amp;rel=1&amp;showsearch=0&amp;showinfo=1&amp;iv_load_policy=1&amp;fs=1&amp;hl=en-US&amp;autohide=2&amp;wmode=transparent" allowfullscreen="true" style="border:0;" sandbox="allow-scripts allow-same-origin allow-popups allow-presentation"></iframe></span></div><p>Right now the software is functional, but it only works on the PinePhone and lacks support for automatic screen rotations. Still, it’s the sort of project that could make it much easier to run desktop applications on Linux phones without the need to plug in a keyboard, mouse, or external display, and I wouldn’t be surprised to see the software or something similar baked into mobile Linux distributions and/or ported to other devices like the Librem 5 smartphone.</p><p><em>via <a href="https://www.reddit.com/r/pinephone/comments/n1ke49/touchpad_emulator_a_virtual_mouse_for_linux/">/r/pinephone</a></em></p><p> </p><section id="text-2" class="below-content widget widget_text"><div class="textwidget"><h4>Share this article:</h4><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-800" class="share-twitter sd-button share-icon" href="https://linuxsmartphones.com/virtual-mouse-app-for-linux-phones-makes-desktop-apps-easier-to-use/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-800" class="share-facebook sd-button share-icon" href="https://linuxsmartphones.com/virtual-mouse-app-for-linux-phones-makes-desktop-apps-easier-to-use/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon" href="https://linuxsmartphones.com/virtual-mouse-app-for-linux-phones-makes-desktop-apps-easier-to-use/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-pinterest"><a rel="nofollow noopener noreferrer" data-shared="sharing-pinterest-800" class="share-pinterest sd-button share-icon" href="https://linuxsmartphones.com/virtual-mouse-app-for-linux-phones-makes-desktop-apps-easier-to-use/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span>Pinterest</span></a></li><li class="share-pocket"><a rel="nofollow noopener noreferrer" data-shared="" class="share-pocket sd-button share-icon" href="https://linuxsmartphones.com/virtual-mouse-app-for-linux-phones-makes-desktop-apps-easier-to-use/?share=pocket" target="_blank" title="Click to share on Pocket"><span>Pocket</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-800" class="share-linkedin sd-button share-icon" href="https://linuxsmartphones.com/virtual-mouse-app-for-linux-phones-makes-desktop-apps-easier-to-use/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span>LinkedIn</span></a></li><li class="share-end"></li></ul></div></div></div></div></section><section id="ai_widget-3" class="below-content widget ai_widget"><div class="code-block code-block-4" style="margin: 8px 0; clear: both;"><div id="ezoic-pub-ad-placeholder-103"> <script async="" src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-2998039209070153" data-ad-slot="4730181379" data-ad-format="auto" data-full-width-responsive="true"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> </div></div></section><section id="ai_widget-8" class="below-content widget ai_widget"><div class="code-block code-block-13" style="margin: 8px 0; clear: both;"> <script async="" src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:block" data-ad-format="autorelaxed" data-ad-client="ca-pub-2998039209070153" data-ad-slot="6078586320"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div></section><section id="custom_html-7" class="widget_text below-content widget widget_custom_html"><h2 class="widget-title">Support LinuxSmartphones.com</h2><div class="textwidget custom-html-widget"><div class="support-box"><p>At LinuxSmartphones.com we strive to provide timely news, opinion, and how-to articles related to the Linux phone space. But it takes time and money to keep this site alive, and while advertising is our primary source of revenue, there are several other ways you can help support this website, even if you&#39;re using an ad blocker.*</p><p></p><h3>Contribute to our <a href="https://www.patreon.com/bradlinder">Patreon campaign</a></h3><p></p><p> <em>or...</em></p><p></p><h3>Contribute via <a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&amp;hosted_button_id=PTBQ9EKAYTZBS&amp;source=url">PayPal</a></h3><p></p> * If you <em>are</em> using an ad blocker like uBlock Origin and seeing a pop-up message at the bottom of the screen, this<a target="blank_" href="https://liliputing.com/2020/09/ublock-origin-how-to-hide-googles-script-blocking-warning-for-websites-using-funding-choices.html" rel="noopener">guide that may help you disable it.</a></div></div></section></div><footer class="entry-footer"> <span class="tags-links"><span>Tagged: </span><a href="https://linuxsmartphones.com/tag/apps/" rel="tag">apps</a><span class="sep">, </span><a href="https://linuxsmartphones.com/tag/calcprogrammer1/" rel="tag">calcprogrammer1</a><span class="sep">, </span><a href="https://linuxsmartphones.com/tag/input/" rel="tag">input</a><span class="sep">, </span><a href="https://linuxsmartphones.com/tag/mouse-emulator/" rel="tag">mouse emulator</a><span class="sep">, </span><a href="https://linuxsmartphones.com/tag/pinephone/" rel="tag">pinephone</a><span class="sep">, </span><a href="https://linuxsmartphones.com/tag/touchpademulator/" rel="tag">touchpademulator</a><span class="sep">, </span><a href="https://linuxsmartphones.com/tag/virtual-mouse/" rel="tag">virtual mouse</a></span></footer></article><div id="comments" class="comments-area"><div class="comments-title-wrap no-responses"><h2 class="comments-title"> Leave a comment</h2></div><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title"> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/virtual-mouse-app-for-linux-phones-makes-desktop-apps-easier-to-use/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://linuxsmartphones.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate=""><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label><textarea id="comment" name="comment" cols="45" rows="5" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required="required" /></p><p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required="required" /></p><p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p><p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Notify me of new posts by email.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type="hidden" name="comment_post_ID" value="800" id="comment_post_ID" /> <input type="hidden" name="comment_parent" id="comment_parent" value="0" /></p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="ce77cde768" /></p><input type="hidden" id="ak_js" name="ak_js" value="225" /><textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100" style="display: none !important;"></textarea></form></div><p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p></div></div><aside id="secondary" class="widget-area"><section id="search-2" class="widget widget_search"><form role="search" method="get" class="search-form" action="https://linuxsmartphones.com/"> <label for="search-form-3"> <span class="screen-reader-text">Search for:</span> </label> <input type="search" id="search-form-3" class="search-field" placeholder="Search …" value="" name="s" /> <button type="submit" class="search-submit"> <svg class="svg-icon" width="28" height="28" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24"><path d="M15.5 14h-.79l-.28-.27C15.41 12.59 16 11.11 16 9.5 16 5.91 13.09 3 9.5 3S3 5.91 3 9.5 5.91 16 9.5 16c1.61 0 3.09-.59 4.23-1.57l.27.28v.79l5 4.99L20.49 19l-4.99-5zm-6 0C7.01 14 5 11.99 5 9.5S7.01 5 9.5 5 14 7.01 14 9.5 11.99 14 9.5 14z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg> <span class="screen-reader-text"> Search </span> </button></form></section><section id="custom_html-6" class="widget_text widget widget_custom_html"><h2 class="widget-title accent-header"><span>Follow</span></h2><div class="textwidget custom-html-widget"><div class="social-icons"> <a href="https://www.facebook.com/LinuxSmartphones/" target="_blank" rel="me noopener"><img src="https://liliputing.com/wp-content/uploads/2020/03/facebook-icon-e1583534816571.png" alt="Facebook" data-lazy-src="https://liliputing.com/wp-content/uploads/2020/03/facebook-icon-e1583534816571.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image" /><noscript><img src="https://liliputing.com/wp-content/uploads/2020/03/facebook-icon-e1583534816571.png" alt="Facebook"/></noscript></a> <a href="https://twitter.com/linuxsmartphone" target="_blank" rel="me noopener"><img src="https://liliputing.com/wp-content/uploads/2020/03/twitter-icon-e1583534797368.png" alt="Twitter" data-lazy-src="https://liliputing.com/wp-content/uploads/2020/03/twitter-icon-e1583534797368.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image" /><noscript><img src="https://liliputing.com/wp-content/uploads/2020/03/twitter-icon-e1583534797368.png" alt="Twitter" /></noscript></a> <a href="https://www.youtube.com/liliputing" target="_blank" rel="me noopener"><img src="https://liliputing.com/wp-content/uploads/2020/03/youtube-icon-e1583534833645.png" alt="YouTube" data-lazy-src="https://liliputing.com/wp-content/uploads/2020/03/youtube-icon-e1583534833645.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image" /><noscript><img src="https://liliputing.com/wp-content/uploads/2020/03/youtube-icon-e1583534833645.png" alt="YouTube" /></noscript></a> <a href="https://linuxsmartphones.com/feed/" target="_blank" rel="noopener"><img src="https://liliputing.com/wp-content/uploads/2020/03/rss-icon-e1583534826300.png" alt="RSS" data-lazy-src="https://liliputing.com/wp-content/uploads/2020/03/rss-icon-e1583534826300.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image" /><noscript><img src="https://liliputing.com/wp-content/uploads/2020/03/rss-icon-e1583534826300.png" alt="RSS" /></noscript></a> <a href="https://www.patreon.com/bradlinder?ty=h" target="_blank" rel="noopener"><img src="https://liliputing.com/wp-content/uploads/2020/03/patreon-icon-e1583534809524.png" alt="Patreon" data-lazy-src="https://liliputing.com/wp-content/uploads/2020/03/patreon-icon-e1583534809524.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image" /><noscript><img src="https://liliputing.com/wp-content/uploads/2020/03/patreon-icon-e1583534809524.png" alt="Patreon" /></noscript></a></div></div></section><section id="text-3" class="widget widget_text"><div class="textwidget"><p>Linux Smartphones is an independent news and information website covering developments in the rapidly growing Linux smartphone space.</p></div></section><section id="ai_widget-2" class="widget ai_widget"><div class="code-block code-block-5" style="margin: 8px 0; clear: both;"><div id="ezoic-pub-ad-placeholder-104"> <script async="" src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-2998039209070153" data-ad-slot="9509398242" data-ad-format="auto" data-full-width-responsive="true"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> </div></div></section><section id="pis_posts_in_sidebar-3" class="widget posts-in-sidebar"><h2 class="widget-title accent-header"><span>Featured articles</span></h2><ul id="ul_pis_posts_in_sidebar-3" class="pis-ul"><li class="pis-li pis-post-516"><p class="pis-thumbnail"><a class="pis-thumbnail-link" href="https://linuxsmartphones.com/can-a-linux-phone-replace-my-iphone-or-android-device/" rel="bookmark"><img width="1200" height="900" src="https://linuxsmartphones.com/wp-content/uploads/2021/01/kde-neon.jpg" class="pis-thumbnail-img aligncenter wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-attachment-id="519" data-permalink="https://linuxsmartphones.com/can-a-linux-phone-replace-my-iphone-or-android-device/kde-neon/" data-orig-file="https://linuxsmartphones.com/wp-content/uploads/2021/01/kde-neon.jpg" data-orig-size="1200,900" data-comments-opened="1" data-image-meta="{&#34;aperture&#34;:&#34;0&#34;,&#34;credit&#34;:&#34;&#34;,&#34;camera&#34;:&#34;&#34;,&#34;caption&#34;:&#34;&#34;,&#34;created_timestamp&#34;:&#34;0&#34;,&#34;copyright&#34;:&#34;&#34;,&#34;focal_length&#34;:&#34;0&#34;,&#34;iso&#34;:&#34;0&#34;,&#34;shutter_speed&#34;:&#34;0&#34;,&#34;title&#34;:&#34;&#34;,&#34;orientation&#34;:&#34;0&#34;}" data-image-title="kde neon" data-image-description="" data-medium-file="https://linuxsmartphones.com/wp-content/uploads/2021/01/kde-neon-400x300.jpg" data-large-file="https://linuxsmartphones.com/wp-content/uploads/2021/01/kde-neon-667x500.jpg" data-lazy-srcset="https://linuxsmartphones.com/wp-content/uploads/2021/01/kde-neon.jpg 1200w, https://linuxsmartphones.com/wp-content/uploads/2021/01/kde-neon-400x300.jpg 400w, https://linuxsmartphones.com/wp-content/uploads/2021/01/kde-neon-667x500.jpg 667w, https://linuxsmartphones.com/wp-content/uploads/2021/01/kde-neon-768x576.jpg 768w, https://linuxsmartphones.com/wp-content/uploads/2021/01/kde-neon-800x600.jpg 800w" data-lazy-sizes="(max-width: 1200px) 100vw, 1200px" data-lazy-src="https://linuxsmartphones.com/wp-content/uploads/2021/01/kde-neon.jpg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a></p><p class="pis-title"><a class="pis-title-link" href="https://linuxsmartphones.com/can-a-linux-phone-replace-my-iphone-or-android-device/" rel="bookmark">Can a Linux phone replace my iPhone or Android device?</a></p></li><li class="pis-li pis-post-425"><p class="pis-thumbnail"><a class="pis-thumbnail-link" href="https://linuxsmartphones.com/video-megis-multi-boot-image-for-the-pinephone-with-17-linux-distros/" rel="bookmark"><img width="1151" height="834" src="https://linuxsmartphones.com/wp-content/uploads/2020/11/p-boot.jpg" class="pis-thumbnail-img aligncenter wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-attachment-id="426" data-permalink="https://linuxsmartphones.com/video-megis-multi-boot-image-for-the-pinephone-with-17-linux-distros/p-boot-2/" data-orig-file="https://linuxsmartphones.com/wp-content/uploads/2020/11/p-boot.jpg" data-orig-size="1151,834" data-comments-opened="1" data-image-meta="{&#34;aperture&#34;:&#34;1.73&#34;,&#34;credit&#34;:&#34;&#34;,&#34;camera&#34;:&#34;Pixel 4a (5G)&#34;,&#34;caption&#34;:&#34;&#34;,&#34;created_timestamp&#34;:&#34;1606326628&#34;,&#34;copyright&#34;:&#34;&#34;,&#34;focal_length&#34;:&#34;4.38&#34;,&#34;iso&#34;:&#34;95&#34;,&#34;shutter_speed&#34;:&#34;0.01667&#34;,&#34;title&#34;:&#34;&#34;,&#34;orientation&#34;:&#34;1&#34;}" data-image-title="p-boot" data-image-description="" data-medium-file="https://linuxsmartphones.com/wp-content/uploads/2020/11/p-boot-400x290.jpg" data-large-file="https://linuxsmartphones.com/wp-content/uploads/2020/11/p-boot-690x500.jpg" data-lazy-srcset="https://linuxsmartphones.com/wp-content/uploads/2020/11/p-boot.jpg 1151w, https://linuxsmartphones.com/wp-content/uploads/2020/11/p-boot-400x290.jpg 400w, https://linuxsmartphones.com/wp-content/uploads/2020/11/p-boot-690x500.jpg 690w, https://linuxsmartphones.com/wp-content/uploads/2020/11/p-boot-768x556.jpg 768w" data-lazy-sizes="(max-width: 1151px) 100vw, 1151px" data-lazy-src="https://linuxsmartphones.com/wp-content/uploads/2020/11/p-boot.jpg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a></p><p class="pis-title"><a class="pis-title-link" href="https://linuxsmartphones.com/video-megis-multi-boot-image-for-the-pinephone-with-17-linux-distros/" rel="bookmark">Video: Megi’s multi-boot image for the PinePhone (with 17 Linux distros)</a></p></li></ul></section><section id="twitter_timeline-2" class="widget widget_twitter_timeline"><h2 class="widget-title accent-header"><span>Latest Tweets</span></h2><a class="twitter-timeline" data-width="300" data-height="600" data-theme="light" data-border-color="#e8e8e8" data-lang="EN" data-partner="jetpack" data-chrome="noheader noscrollbar" href="https://twitter.com/linuxsmartphone" href="https://twitter.com/linuxsmartphone">My Tweets</a></section><section id="pis_posts_in_sidebar-2" class="widget posts-in-sidebar"><h2 class="widget-title accent-header"><span>Recent Posts</span></h2><ul id="ul_pis_posts_in_sidebar-2" class="pis-ul"><li class="pis-li pis-post-800 current-post"><p class="pis-thumbnail"><a class="pis-thumbnail-link" href="https://linuxsmartphones.com/virtual-mouse-app-for-linux-phones-makes-desktop-apps-easier-to-use/" rel="bookmark"><img width="1200" height="673" src="https://linuxsmartphones.com/wp-content/uploads/2021/04/touchpademulator.jpg" class="pis-thumbnail-img aligncenter wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-attachment-id="801" data-permalink="https://linuxsmartphones.com/virtual-mouse-app-for-linux-phones-makes-desktop-apps-easier-to-use/touchpademulator/" data-orig-file="https://linuxsmartphones.com/wp-content/uploads/2021/04/touchpademulator.jpg" data-orig-size="1200,673" data-comments-opened="1" data-image-meta="{&#34;aperture&#34;:&#34;0&#34;,&#34;credit&#34;:&#34;&#34;,&#34;camera&#34;:&#34;&#34;,&#34;caption&#34;:&#34;&#34;,&#34;created_timestamp&#34;:&#34;0&#34;,&#34;copyright&#34;:&#34;&#34;,&#34;focal_length&#34;:&#34;0&#34;,&#34;iso&#34;:&#34;0&#34;,&#34;shutter_speed&#34;:&#34;0&#34;,&#34;title&#34;:&#34;&#34;,&#34;orientation&#34;:&#34;0&#34;}" data-image-title="touchpademulator" data-image-description="" data-medium-file="https://linuxsmartphones.com/wp-content/uploads/2021/04/touchpademulator-400x224.jpg" data-large-file="https://linuxsmartphones.com/wp-content/uploads/2021/04/touchpademulator-780x437.jpg" data-lazy-srcset="https://linuxsmartphones.com/wp-content/uploads/2021/04/touchpademulator.jpg 1200w, https://linuxsmartphones.com/wp-content/uploads/2021/04/touchpademulator-400x224.jpg 400w, https://linuxsmartphones.com/wp-content/uploads/2021/04/touchpademulator-780x437.jpg 780w, https://linuxsmartphones.com/wp-content/uploads/2021/04/touchpademulator-768x431.jpg 768w" data-lazy-sizes="(max-width: 1200px) 100vw, 1200px" data-lazy-src="https://linuxsmartphones.com/wp-content/uploads/2021/04/touchpademulator.jpg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a></p><p class="pis-title"><a class="pis-title-link" href="https://linuxsmartphones.com/virtual-mouse-app-for-linux-phones-makes-desktop-apps-easier-to-use/" rel="bookmark">Virtual mouse app for Linux phones makes desktop apps easier to use</a></p></li><li class="pis-li pis-post-794"><p class="pis-thumbnail"><a class="pis-thumbnail-link" href="https://linuxsmartphones.com/plasma-mobile-picks-up-new-apps-app-updates-and-the-beginnings-of-multiple-home-screens/" rel="bookmark"><img width="782" height="773" src="https://linuxsmartphones.com/wp-content/uploads/2021/04/plasma-mobile.jpg" class="pis-thumbnail-img aligncenter wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-attachment-id="797" data-permalink="https://linuxsmartphones.com/plasma-mobile-picks-up-new-apps-app-updates-and-the-beginnings-of-multiple-home-screens/plasma-mobile-3/" data-orig-file="https://linuxsmartphones.com/wp-content/uploads/2021/04/plasma-mobile.jpg" data-orig-size="782,773" data-comments-opened="1" data-image-meta="{&#34;aperture&#34;:&#34;0&#34;,&#34;credit&#34;:&#34;&#34;,&#34;camera&#34;:&#34;&#34;,&#34;caption&#34;:&#34;&#34;,&#34;created_timestamp&#34;:&#34;0&#34;,&#34;copyright&#34;:&#34;&#34;,&#34;focal_length&#34;:&#34;0&#34;,&#34;iso&#34;:&#34;0&#34;,&#34;shutter_speed&#34;:&#34;0&#34;,&#34;title&#34;:&#34;&#34;,&#34;orientation&#34;:&#34;0&#34;}" data-image-title="plasma mobile" data-image-description="" data-medium-file="https://linuxsmartphones.com/wp-content/uploads/2021/04/plasma-mobile-400x395.jpg" data-large-file="https://linuxsmartphones.com/wp-content/uploads/2021/04/plasma-mobile-506x500.jpg" data-lazy-srcset="https://linuxsmartphones.com/wp-content/uploads/2021/04/plasma-mobile.jpg 782w, https://linuxsmartphones.com/wp-content/uploads/2021/04/plasma-mobile-400x395.jpg 400w, https://linuxsmartphones.com/wp-content/uploads/2021/04/plasma-mobile-506x500.jpg 506w, https://linuxsmartphones.com/wp-content/uploads/2021/04/plasma-mobile-768x759.jpg 768w" data-lazy-sizes="(max-width: 782px) 100vw, 782px" data-lazy-src="https://linuxsmartphones.com/wp-content/uploads/2021/04/plasma-mobile.jpg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a></p><p class="pis-title"><a class="pis-title-link" href="https://linuxsmartphones.com/plasma-mobile-picks-up-new-apps-app-updates-and-the-beginnings-of-multiple-home-screens/" rel="bookmark">Plasma Mobile picks up new apps, app updates, and the beginnings of multiple home screens</a></p></li><li class="pis-li pis-post-785"><p class="pis-thumbnail"><a class="pis-thumbnail-link" href="https://linuxsmartphones.com/pinephone-keyboard-prototype-transforms-the-linux-phone-into-a-tiny-linux-laptop/" rel="bookmark"><img width="1026" height="813" src="https://linuxsmartphones.com/wp-content/uploads/2021/04/pp-kb_02.jpg" class="pis-thumbnail-img aligncenter wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-attachment-id="789" data-permalink="https://linuxsmartphones.com/pinephone-keyboard-prototype-transforms-the-linux-phone-into-a-tiny-linux-laptop/pp-kb_02/" data-orig-file="https://linuxsmartphones.com/wp-content/uploads/2021/04/pp-kb_02.jpg" data-orig-size="1026,813" data-comments-opened="1" data-image-meta="{&#34;aperture&#34;:&#34;0&#34;,&#34;credit&#34;:&#34;&#34;,&#34;camera&#34;:&#34;&#34;,&#34;caption&#34;:&#34;&#34;,&#34;created_timestamp&#34;:&#34;0&#34;,&#34;copyright&#34;:&#34;&#34;,&#34;focal_length&#34;:&#34;0&#34;,&#34;iso&#34;:&#34;0&#34;,&#34;shutter_speed&#34;:&#34;0&#34;,&#34;title&#34;:&#34;&#34;,&#34;orientation&#34;:&#34;0&#34;}" data-image-title="pp kb_02" data-image-description="" data-medium-file="https://linuxsmartphones.com/wp-content/uploads/2021/04/pp-kb_02-400x317.jpg" data-large-file="https://linuxsmartphones.com/wp-content/uploads/2021/04/pp-kb_02-631x500.jpg" data-lazy-srcset="https://linuxsmartphones.com/wp-content/uploads/2021/04/pp-kb_02.jpg 1026w, https://linuxsmartphones.com/wp-content/uploads/2021/04/pp-kb_02-400x317.jpg 400w, https://linuxsmartphones.com/wp-content/uploads/2021/04/pp-kb_02-631x500.jpg 631w, https://linuxsmartphones.com/wp-content/uploads/2021/04/pp-kb_02-768x609.jpg 768w" data-lazy-sizes="(max-width: 1026px) 100vw, 1026px" data-lazy-src="https://linuxsmartphones.com/wp-content/uploads/2021/04/pp-kb_02.jpg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a></p><p class="pis-title"><a class="pis-title-link" href="https://linuxsmartphones.com/pinephone-keyboard-prototype-transforms-the-linux-phone-into-a-tiny-linux-laptop/" rel="bookmark">PinePhone keyboard prototype transforms the Linux phone into a tiny Linux laptop</a></p></li></ul></section><section id="ai_widget-7" class="widget ai_widget"><div class="code-block code-block-9" style="margin: 8px auto; text-align: center; display: block; clear: both;"><div id="ezoic-pub-ad-placeholder-106"> <script async="" src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-2998039209070153" data-ad-slot="3868287197" data-ad-format="auto" data-full-width-responsive="true"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> </div></div></section><section id="meta-2" class="widget widget_meta"><h2 class="widget-title accent-header"><span>Meta</span></h2><ul><li><a rel="nofollow" href="https://linuxsmartphones.com/wp-login.php">Log in</a></li><li><a href="https://linuxsmartphones.com/feed/">Entries feed</a></li><li><a href="https://linuxsmartphones.com/comments/feed/">Comments feed</a></li><li><a href="https://wordpress.org/">WordPress.org</a></li></ul></section></aside></main></section></div><footer id="colophon" class="site-footer"><div class="site-info"><div class="wrapper site-info-contain"> <span class="copyright">© 2021 LinuxSmartphones.com // Linux® is the registered trademark of Linus Torvalds.</span> <a href="https://newspack.pub/" class="imprint"> Proudly powered by Newspack by Automattic </a> <a class="privacy-policy-link" href="https://linuxsmartphones.com/privacy-policy/">Privacy Policy</a></div></div></footer></div><div style="display:none"><div class="grofile-hash-map-558f8da606ef78c7c9214fb9cc2bb0a1"></div></div> <script type="text/javascript">window.WPCOM_sharing_counts = {"https:\/\/linuxsmartphones.com\/virtual-mouse-app-for-linux-phones-makes-desktop-apps-easier-to-use\/":800};</script> <script type="text/javascript" src="https://secure.gravatar.com/js/gprofiles.js?ver=202117" id="grofiles-cards-js"></script> <script type="text/javascript" id="wpgroho-js-extra">var WPGroHo = {"my_hash":""};</script> <script type="text/javascript" id="newspack-amp-fallback-js-extra">var newspackScreenReaderText = {"open_search":"Open Search","close_search":"Close Search","expand_comments":"Expand Comments","collapse_comments":"Collapse Comments","show_order_details":"Show details","hide_order_details":"Hide details"};</script> <script type="text/javascript" id="jetpack-lazy-images-js-extra">var jetpackLazyImagesL10n = {"loading_warning":"Images are still loading. Please cancel your print and try again."};</script> <script type="text/javascript" id="jetpack-carousel-js-extra">var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/linuxsmartphones.com\/wp-admin\/admin-ajax.php","nonce":"5306e92481","display_exif":"0","display_comments":"0","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/linuxsmartphones.com\/wp-login.php?redirect_to=https%3A%2F%2Flinuxsmartphones.com%2Fvirtual-mouse-app-for-linux-phones-makes-desktop-apps-easier-to-use%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};</script> <script type="text/javascript" id="sharing-js-js-extra">var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};</script> <script type="text/javascript" id="sharing-js-js-after">var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-twitter' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-twitter' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-facebook' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-facebook' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-pocket' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-pocket' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcompocket', 'menubar=1,resizable=1,width=450,height=450' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-linkedin' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-linkedin' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
						return false;
					}
				} );
			} )();</script> <script>/(trident|msie)/i.test(navigator.userAgent)&&document.getElementById&&window.addEventListener&&window.addEventListener("hashchange",function(){var t,e=location.hash.substring(1);/^[A-z0-9_-]+$/.test(e)&&(t=document.getElementById(e))&&(/^(?:a|select|input|button|textarea)$/i.test(t.tagName)||(t.tabIndex=-1),t.focus())},!1);</script> <script src="https://stats.wp.com/e-202117.js" defer=""></script> <script>_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.6.1',blog:'182311836',post:'800',tz:'-4',srv:'linuxsmartphones.com'} ]);
	_stq.push([ 'clickTrackerInit', '182311836', '800' ]);</script> <script>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</script> <script defer="" src="https://linuxsmartphones.com/wp-content/cache/autoptimize/js/autoptimize_8031c1405e0ee0901ff471772cdc948d.js"></script>
<script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('/detroitchicago/edmonton.php', '/detroitchicago/edmonton.webp?a=a&cb=0&shcb=34', true, ['/detroitchicago/minneapolis.js'], true, false, false, false);
__ez.queue.addFile('/porpoiseant/jellyfish.php', '/porpoiseant/jellyfish.webp?a=a&cb=0&shcb=34', false, [], true, false, false, false);
</script>
<script>var _audins_dom="linuxsmartphones_com",_audins_did=243656;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=194-0");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.linuxsmartphones_com,DomainId.243656" border="0" height="1" width="1" alt="Quantcast"/></div></noscript>
<script type="text/javascript" data-cfasync="false"></script>
<script>__ez.queue.addFile('/tardisrocinante/vitals.js', '/tardisrocinante/vitals.js?gcb=0&cb=3', false, ['/detroitchicago/minneapolis.js'], true, false, true, false);</script></body></html>